Commits


CHANGES for 0.58


sync dist file list


fix a null-pointer deref in 'got fetch -d'; reported by Omar Polo


fix name of temporary directory used by test_fetch_delete_remote_refs


remove obsolete sentence from got_dial_parse_uri() docs


add missing <sys/types.h> include


make 'gotadmin info' display separate send/fetch URLs if they differ


mention where the 'proto' parameter of got_dial_apply_unveil() comes from


fix documentation of got_dial_apply_unveil()


document functions declared in the public got_dial.h header file


remove declaration of got_fetch_parse_uri()


fix regress/fetch build; broken by my renaming of got_fetch_parse_uri()


assert against accidentally overflowing argv[] in got_dial_ssh() ok stsp


rename got_fetch_parse_uri() to got_dial_parse_uri() This function is now being used by both 'got fetch' and 'got send' so its former name was misleading.


de-duplicate a constant used by both 'got fetch' and 'got send' Both GOT_FETCH_PKTMAX and GOT_SEND_PKTMAX had the same value. Declare this value as GOT_PKT_MAX in got_lib_pkt.h instead.


move duplicated dial_ssh() and dial_git() functions into a common file These functions are used by 'got send' and 'got fetch' in order to open network connections to a server. Move them into new file lib/dial.c and declare relevant functions in got_dial.h and lib/got_lib_dial.h. No functional change.


indentation fixes


whitespace fix


move more code used by got-send-pack and got-fetch-pack to a common file Move functions and data structures which implement Git protocol features required for fetching and sending pack files to new files lib/gitproto.c and lib/got_lib_gitproto.h. This code was duplicated in got-fetch-pack and got-send-pack. No functional change.


move pkt code used by got-fetch-pack and got-send-pack to a common file The Git protocol uses a simple packet framing format. The got-fetch-pack and got-send-pack programs contained identical copies of functions to support this format. Move related functions to new file lib/pkt.c and link both programs against this common implementation. No functional change.


tog: when jumping to the bottom of the log view, go from the tail backwards ok jasper


make "got branch -d" print reference name and value Also silence output of "got branch -d" in a regression test, from stsp. ok stsp


tog: jump directly to first log item instead of traversing the list ok tracey


tog: add support for navigating to first/last line of tree and ref views ok stsp


bump version number